+1
Under review

Dragging node hardly works on Linux

Brendan Weibrecht fa 4 anys updated by Jeffrey Gipson fa 11 mesos 6

Dragging a node is very difficult now on my Linux machine, since about a week ago. Nothing changes under the mouse I while I'm dragging the tab, and then when I release it, Tabs Outliner is frozen for about 10 seconds, then finally moves the tab.


I have 15,287 nodes, so I don't know if this is related. Luckily I am still able to move things around with the keyboard shortcuts for now.

Answer

+1
Answer

I tested with 20 000 visible nodes with Chrome Canary and looks like this bug is fixed in Canary now. But it might take several months actually until current Chrome version will be replaced by current Canary version.

The lag time is proportional to the distance dragged. It is only a few seconds to move the tab slightly, but from the bottom of the window to the top is about 10. Dragging it from the bottom of the window, out the side, then back in near the top is much faster - only a few seconds. Perhaps it has to do with displaying the new location in the tree whilst dragging.

+1
Under review

Hi

Unfortunately, this is a bug that is introduced in the latest Chrome release (interesting that such bug was already present a year ago, then they fixed it, now it's reaper again). And yes, most likely it's related to tree size, it's seems work normal with small tress.

For now i still not have a solution. chrome hang in some internals during Drag&Drop, without possibility to intervene. But i hope i will find some workaround and of course i plan to fix this, i myself have around 60 000 nodes and Drag & Drop is basically not working anymore for me either.
Not very sure but seems that in  Chrome Canary maybe this issue actually fixed, through i not test with really  big trees...

For now the only thing i might suggest is to just export tree through Ctrl-S or/and just save backup to File and start from scratch... 

+1
Answer

I tested with 20 000 visible nodes with Chrome Canary and looks like this bug is fixed in Canary now. But it might take several months actually until current Chrome version will be replaced by current Canary version.

Thank you very much for your detailed response! I'm glad to know the fix is made and on the horizon. I will make do until it reaches Chrome Stable.

Possibly related: Dragging nodes is hard on Linux (Open Suse Leap 15.3) due to a display bug.

Note how the dragged item contains unnecessary parts of a screenshot. This makes aiming the "drop" part of drag and drop pretty hard.

More complete screenshot:

I had trouble dragging on Linux until I DISABLED this feature:

chrome://flags/#use-ozone-platform