0
Fast

Phantom Tabs

MZ Guy 9 år siden opdateret af vladyslav volovyk 8 år siden 32

I'm not sure this has been posted about before. When browsing, I have recently noticed a behavior/bug that was not present before I went to Chrome v26. Sometimes tabs stay in Tabs Outliner after they have been closed. These are tabs that were generally (always?) closed via Chrome's interface (the 'x' on the tab), or by closing the entire window with the 'x'.Furthermore, they often show up in a different part of the tree (different window) than where they were originally. Clicking on them does nothing, but they can be removed with the trash icon.


Additionally, Chrome about:memory shows some usual results. Right now, I have a "tab" line item using 700K of memory with 8 lines under it that say merely "Google". This whole beast shares the same PID. I have no idea what this is as I don't have any tabs open that are named just "Google". Things like this started showing up in the memory detail screen when the aforementioned bug started appearing. They usually waste a lot of memory.


Great extension by the way, thanks!

Svar

Svar
Fast

The Phantom Tabs Bug must be fixed for now in v0.4.72 


> Furthermore, they often show up in a different part of the tree (different window) than where they were originally. 


Are you 100% sure?


Also, did you enable the Tabs Outliner in Incognito mode? (not recommended by the way)

Oh yes, 100% sure. I keep things very organized in Tabs Outliner. I have seen it multiple times, and noticed particularly because the tabs in question were out of place. I just checked, Tabs Outliner is not enabled in Incognito Mode.

To clarify, I'm not sure exactly when the tabs reappeared in a different part of the tree and different window. I suspect it may have been immediately upon closing, but I don't really know.


Will ask once again to clarify.

I am sure that you saw the Phantom Tabs.


What i ask and trying to understand - is the Phantom Tabs appears not in a window they was closed. Or you not absolutely sure in this?


Also will be cool to know the urls...


I maybe known some reasons for this effect. And plan to fix (yet unfortunately never seen it in my tree). But in current my theory of how they appears they cannot change the window, if this is what i am thinking about.


Also please mention your Tabs Outliner version (can be seen in about window).

The URLs have varied... random sites seemingly. I no longer can remember what they were. I am 99% certain the tabs changed windows on at least one occasion as well. I will post again if I see it again. It may be a few days before it recurs.

Just saw one where it was marked unloaded after I had closed it, but did not respond to left-clicks.... it was a simple google search. It did not switch windows.

Just to be sure, please mention your version of TO.


There was such problem after Chrome v26 was released. It has some bugs. So i did workaround a version or 2 ago. And looks like it cover most of the such cases. Yet of course it might be not complete. But also it is possible that you use not updated version of TO.

Sorry - you did ask me that! I'm running 0.4.56

Ok, that is the latest version...

Then that is means my workaround is not completely complete...

Bad that i cannot reproduce this myself.

But i have some ideas of what can be done, will try in next release (in 2-3 days).


There was similar problem after Chrome v26 update, it did happens when users manually type something in address bar, sometimes, very rarely, but i was managed to reproduce it and cover. Is this same or something another need investigate but i will do some changes.

if you can please make some screenshots of this Phantom Tabs and the window node in which they happen.


Or just describe is the window node which contain 

such tab is gray (saved) or blue?

The one I saw today was in an open, active, and saved (named window).

It's likely that every tab I've seen with this issue was in a saved window or group. I tend to name a lot of my windows / groups. That might help you hunt down the problem.


As for the strange memory details screen, do you know if that's related? For example, I have the following using 256K right now:

Tab

Google

Google
Google
las - Google Search

I never searched for las, unless that was a partial search that I cancelled or immediately closed. Searching the entire expanded tab tree shows no tabs with the text "las" in them. So this seems to be a case where there's a phantom tab in memory but doesn't appear in the tree.

As about strange phantoms in memory details screen - this is 100% not related to Tabs Outliner. Maybe some Chrome internal problems or some other extension.

One more hopefully useful bit of info: I closed the tab for this forum post, and it stayed in my chrome:memory list! I did not type the address directly in the URL bar. I clicked on it from my Gmail account after receiving a notification.

I keep finding more... 


I looked again, and next to the "las - Google Search" in my memory detail, I now see "about - Google Search". I know that just a few minutes ago I opened a new tab, typed "about" in the URL, erased it (backspace), typed some other things, then closed the tab. I was trying to remember how to get the memory detail for chrome://memory, and having previously been a Firefox user I started typing "about" out of habit (for about:memory). 


As I mentioned before, there's some other "litter" in memory that didn't come from typing in the URL bar, but rather from clicking on a link.

I done some changes. Please notify me if you again encounter this phantom tabs. It might help, or might not. Have in mind some more approaches. But actually changes that i done might solve this issue already. 

Version 0.4.62 just made a new phantom tab. A site I just opened and then closed, showed up in a different window, but one nested as such.


Group A (saved window)

Subgroup A.1 (saved window)

Subgroup A.2 (saved window)

Phantom window appeared here. Still shows "loading" spinning circle. Claims to be loaded (light blue), but clicking on it does nothing. Has a green dot in the box (saved), but its peers within this subgroup do not. Was able to close it with red trash icon.

Subgroup A.3 (saved window)

Original location of closed window

Ok, thanks, so need done some more work... Have some guesses what might help, but....

I hope that this is not a super critical, as I need take a small pause from maintenance releases, for 2-3 weeks maybe, and concentrate on new features.

Yet the exact scenario which always reproduce the problem of course will help to solve this problem immediately.

Mentioning the url might help by the way, as i think it is more likely to occur with some specific sites who's actively utilize redirects.


Can't recall which site right now, but I know it was a blogspot.com blog. It has also happened in the past with this UserEcho site.

I'm also experiencing this issue, but with all tabs.  I'm having to close tabs from within TO in order to get them to work.


TO Version 0.4.71

Chrome Version 29.0.1541.0

Cannot reproduce this, what is the OS you use?

Any luck with your issue Jonathon? If you're experiencing this with every tab, perhaps that's the root of the problem. I still have this issue on a regular basis.


Sorry guys, was very busy to publish some fixes. Yet i am really surprised that you experience this so severe.


I am actually never be able to reproduce this, i have only theoretical ideas how this potentially might happens (yep yes, there is real problem in code in this regards, and i have idea how to fix, but i really never experienced its on any of my testing platforms)

Can you mention some links maybe where this happens most of the time, your OS and Chrome version.

Also how this happens - do you enter by hand some text in address bar before this? The exact scenario of what are you doing will be very helpfully. As it might be not what i think at all.


maybe you can reproduce this problem and record a screencast of this using some of the free services:


like:

http://www.screencast-o-matic.com/

or

http://www.screenr.com/


this will be helpful i think


Wish I could reproduce this on demand, but I don't know how. I'd have to have a screencast running for a long time, sharing all kinds of things on my screen that I don't want to share! 


To answer your question though: the vast majority of time this occurs when I do a search by typing in the address bar. Most of my phantom tabs end up being Google search tabs. Most, but not all. 

This is actually looks like a scenario that i have in mind. Needs wait for a next release, i try to fix this in it. 


What is OS and Chrome version by the way?



Sounds good; I hope your idea will fix it! Can you post here when you post the update with the fix? I want to make sure I make a note of the update and look for the problem recurring.


I am using:

Windows 7; latest Chrome 28.0.1500.72 m

It has been occurring for the past several updates of Chrome as well.


> Can you post here when you post the update with the fix? 

Sure, i will set fixed state for the bug. this must lead to notification for all the participants.

Also, they often have a "still loading" spinning circle in TO next to them, for a long period of time.

Svar
Fast

The Phantom Tabs Bug must be fixed for now in v0.4.72 


I'm getting a lot of strange behaviour in Tabs Outliner now. This started a few days ago.

There are Phantom Tabs (closing a tab in Chrome doesn't remove it from TO), and I'm also losing tabs when I quit Chrome (a Window had 5 tabs in it, I restarted Chrome, and now it only has 1 tab in it.)

The Phantom tabs only seem to happen when I quit Chrome and try to reopen the tab.

Could it be that my Tab Outliner database has gotten corrupted? Can I get your email so I can send you the database to look at?
Tabs Outliner does not save tabs on Chrome exit if they does not contain any notes or if the window with them didn't have a custom title.

That's in theory. In practice there is a bug, and on Chrome exit tabs often become saved in the tree as crashed. But not always

I am not sure you are talking about this problem or about something else. I just tried with different Chrome versions - and i cannot reproduce situation when tab after being closed in Chrome still stay in the tree (if they not having any notes on self).

So if you have a sure step by step scenario to reproduce this problem please describe it. Also please mention your Chrome version and your OS.

Best Regards,
Vladyslav

PS If Tabs Outliner works and render the tree then the  database is 100% not corrupted or broken. Also if for any reason you need to contact me privately - my email is present in about (info) dialog in Tabs Outliner.

Kundesupport af UserEcho