can't restore backup, Google Drive error

Rainer 4 aastat tagasi uuendaja Maah Luz 1 aasta tagasi 34

As of this morning I can't restore backups. It seems to be an issue with Google Drive. When I try to restore the TO window is shown, but this error pops up:

Error: A network error occurred, and the download could not be completed. Check you Internet connection.

If I look at the URL it is trying to open and try to open the https://content.googleapis.com/drive/v2/files/..... part directly then I get: 403 Forbidden Your client does not have permission.

I'm hoping this is a transient Google Drive issue, but wondering if anyone knows more.

Same problem here. RESTORE not working any more. This is new - several days ago everything worked as expected.

Interestingly, I can still save backups.

Yes, it is a problem with restore feature as far as I can tell. Backup itself is OK.

One question arises, though: what good is a backup if you cannot restore it later :)

Same issue here. Backup works but not restore.


Same issue here trying to download tabs saved on my other computer, which used to work well.  I can see all of the backups from both this and my laptop, but cannot view any of the cloud saved ones any longer - not even the ones saved from this computer!

Same issue here, been happening for a few weeks now

Nothing changes. Still the same. Maybe it is some change in Google Drive API that broke T.O.  ?

Same issue here, I can make backups but when I try to restore then it gives a error. Any ideas how to fix this?


same issue here. Updated chrome and restarted, stupid chrome did not sync , so re-installed & logged in again.

getting the same error (Error: A network error occurred, and the download could not be completed. Check you Internet connection.) on restore. Any help on how to resolve is greatly appreciated.

I enabled the error log on the chrome extension and this is what I see.

Access to XMLHttpRequest at ({BIG_URL})

from origin 'null' has been blocked by CORS policy: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource.

I am having the same issue.

Is the developer looking into this?

Not looking, I think. Had they been they would have responded by now. Could be the developers are no longer around? That would be quite sad.

same remote issue on mac and pc. local backups are accessible for me.

Looks like ACVEER has some great clues.

You mean clues for the developer, right?


There's a temporary workaround so you can open your backups normally.

First you need to load a copy of Tabs Outliner extension locally in Developer Mode.

1. Disable the original Tabs Outliner extension in Chrome (chrome://extensions/).

2. Find the extension in the Extensions folder under Chrome's Application Data.

    On Windows it's here:

 C:\Users\%Username%\AppData\Local\Google\Chrome\User Data\Default\Extensions\eggkanocgddhmamlbiijnphhppkpkmkl\

3. Copy that entire extension's folder (1.4.134_0) and paste it somewhere else.

4. Delete _metadata folder in your copy.

5. Replace original options-backup.js in \backup\ with this file.

    The only change is one parameter of viewTree function from "path"

    to "path.replace("content.googleapis.com", "www.googleapis.com")".

    See details here.

6. Enable Developer Mode on Chrome Extensions page (chrome://extensions/) and then "Load Unpacked" on the folder with your modified Tabs Outliner.

Then enable Google Drive backups in the Options, granting access to your Gmail account (like you did before).

Now the modified TO should download your previous backups from Google Drive and you will be able to open them.


Thanks mate. This works on OSX as well. location of chrome folder on OSX. Inside chrome folder, look for Profile{X}/extensions/eggkanocgddhmamlbiijnphhppkpkmkl where x is the number chrome assigns for your login. like Profile4 or Profile2. etc.

~/Library/Application Support/Google/Chrome

Wow, it worked! 

Thanks so much for finding the workaround for this @566-eliio ! 

Any idea how to regain the pro licence features (which I paid for, but which now no longer seem to automatically turn on when I access my Google Drive account)? 

[ P.S. I might add, in your final step instructions, maybe to write the final detail about selecting the folder: 

6. ...click "Load Unpacked" and browse to the modified version of the "1.4.134_0" folder (with the replaced options-backup.js file in the \backup\ sub-directory), and click "select folder." ]

You’re welcome. I'm using free version, so unfortunately don't know how to activate the modified version. But maybe it can accept your old activation if you try to activate it again, because the extension is all the same, it's just loaded locally.

Okay, I figured out that to restore the paid licence 'pro' features, you need to go back to the acknowledgement email and open the link URL there in the same browser that you have Tabs Outliner installed on. 

Seems to work fine again now, on the version with the modification of the "options-backup.js" file. :)

yeah... exactly.  This is kind of strange. I guess one can still get the paid version, but the author seems to be gone. Soo... where does the money go? Interesting....

I don't know who you are. I've never met you, and I never will. But I love you. Thank you so much. This has been a pain in my ass for weeks now, and I'd all but given up hope of ever seeing a solution. Thank you.

Except... this is hardly a solution. As the author stated: more of a [temporary] workaround.

TO developer / maintainer should issue a proper fix for this.

Thank you EliiO, it actually worked! I can open old backups now. Unfortunately, I'm 3 weeks late, since the last available backup in my Google Drive Backups in Tabs Outliner is from 3 weeks after I last managed to make a backup. I assume the admin saves the user backups on a server somewhere and deletes the files that are older than 3 weeks. The admin has gone rogue, so it seems like I'm out of luck. Thanks anyway!

options-backup.js doesnt exist on my tabs outliner folder to be replaced i think something changed 

Confirmed operational. All is good now. Side question: it is possible to open a group from the local TO window. However, when a backup from GoogleDrive is opened it is different. One can open any individual link from a saved tab, but not the entire group as originally backed up. Why is that? (by the way: it was always like that - even before the Restore functionality stopped working).

Yes, for me it's the same, only individual links are clickable. Maybe this feature could be released in the future versions.

How was it...? Days of Future Past.

The only way to manipulate a backup group is to drag it from a backup to TO main window tree.

Noticed the mention in original help files: 

  • Links can be opened directly from Backup View with Ctrl-Click (Middle-Click) or Shift-Click, as Backup view is just an a regular HTML page. (This shortcuts also works in Main View).

All good, but the group cannot be opened from the Backup View. Which could be realized as a series of "open new tab" actions on all of the links in the group, I believe.


Same here. So, did GDrive URL changed and the extension needs to be updated?

Looks like author is long gone and haven't even cared to bother helping us :( I guess he himself isn't using it anymore.


Hi, I'm using TO for a long time and I use it in a daily basis.
I've found an alternate workaround -Thanks to EliiO for a deep and technical solution, but it was not easy enough for me- into TO with no other requirements.

This procedure is short, secure and simple, but manual:

1. Open TO Options and Backup tab.

2. Go to Export section

3. click on Export Tree To File button. TO downloads a convenient named file (tree-exported-[date].tree).

That's it. Continue to Recovery task.

4. Verify the file by clicking on the button Select file next to View Exported Tree. The OS -win 10 is the mine- opens a filtered list of *.tree files to select from. 

Just pick one; at this point data come back to life. The file is not only visible, but almost a full functional TO window -copy+paste, drag'n drop, expand|collapse nodes...-.

5. Proceed to pick a node to recover and Drag'n Drop it to the Main TO Window. 'Current Session' for entire file restore or any other branch node for any piece of data.

This one worked for me.

Hopefully, It'd work for you too

....YES, at this moment We've lost any automatic backing up.



Accessing Google Drive Backups seems fixed, probably thanks to the extension's update on the April 30, 2020. Confirmed on 2 different computers: they can both access their backups and the other ones.

Edit: no workaround applied since network error occurred for the first time.


Yes, accessing Google Drive Backups works now, but unfortunately the last available backup in my Google Drive Backups in Tabs Outliner is from 3 weeks after I last managed to make a backup. So I still can't recover all my work from the last 3 years, since I don't think the admin stores older backups and he's gone rogue.

Please! Can someone help me find out where old backups are stored!? I'm willing to pay an award for the recovery of any of my old backups from before Feb 20, 2020. The last one I have before this network error occurred is from 2016. So I've lost everything from the past 4 years, and my work will fire me if I don't get it back. I'm really freaking out and desperate.

TO cloud backups are stored on Google Drive and I'm afraid the old ones beyond the number of "Keep last" in the Options are deleted. May be there is a global Google Drive backup, but I don't know if it possible for the users to get access to these backups. May be the author knows more, but as we see he doesn't answer at all. You may try to ask Google Drive Support or Community. But unfortunately it's almost no chance that deleted by an app backups can be restored.