+4

main window not appearing

BaliDave 2 ár síðan updated by James Heck 5 mánuður síðan 7

I'm a long time TO user who relies and loves it.  But suddenly after shutting down Chrome I cannot get the main TO window (the one you click on to open tabs) to appear at all!  Clicking on the TO icon in Chrome (that shows the number of tabs open) used to bring up that window.  And my pinned icon in the task bar for it doesn't do work either.  This window is NOT off-screen, it's just not there.  It works fine on my laptop. Rebooting didn't help either.

I have several thousand tabs in various groups.  I can see what they are by viewing the backups, but I can't get that listing to be the main TO window.  Anyone have any ideas on how to restore that?

When I look in Chrome's extensions page, TO extension has "Errors" link in red.  Clicking on that shows the errors TO is getting when I try to bring up the navigation (main) TO window.  So when I click on the TO icon in Chrome's toolbar to try to bring up the TO nav window,  the  error is

ERROR############# onTabCreated # Cannot find openerTabNode in window hierarchy. windowId: 180 openerTabId: 164

See below.  Any ideas on how to get around this?

+1

For the benefit of anyone else who has this problem & is a paid user: I resolved it by 

  • doing an Export tree of a good version of my tree from my backups in the TO Backups window
  • removing TabsOutliner from Chrome and restarting Chrome
  • reinstalling TO and opting for paid mode (maybe there's a way to avoid this ???, but at this point ...)
  • double clicking the exported .tree file so it appears in a window
  • opening TO's main window and then dragging my exported tree over to it

So now I've got everything from before and back in business with TO, tho $20 poorer ;-)

Tks for the suggestion. I did mostly that from the free version. Opening the lastest  backup and dragging from it.

+5

This may be due to multiple monitors or screen resolution. In the options, try unchecking "Open Tabs Outliner in the same position and size where it was last closed." Relevant thread: https://tabsoutliner.userecho.com/is/communities/1/topics/519-restoring-a-closed-window-or-tab-fails-when-windowtab-is-50-outside-the-visible-screen-space

How are you supposed to open the options if you can't open TO? Try going back to your multi-monitor setup. If you can't... :-/

Thanks, but I'm on a single HD monitor and have been.  Also I believe I didn't have that option checked, it's not now.  But with similar error messages,The error is somehow related tho, judging from the what we see and the timing of that Chrome update.  Just hope I can avoid that happening again.

This worked!!  Many Thanks!  I unchecked the box as suggested, and it then worked immediately.

I also "fixed" the missing window by removing / reinstalling the extension.

None of my tabs were lost,

but somehow my license was .. trying to figure out how to restore that.